Intermittent Access to my.vcu.edu and VCU Mobile
Minor incident
E-mail & Collaboration
VCU Mobile App
Web Applications
myVCU Portal
2026-08-24 10:14 EDT
· 1 hour, 39 minutes
Updates
Resolved
August 24, 2026 · 11:53 EDT
The intermittent access issues affecting my.vcu.edu and the VCU Mobile app have been fully resolved. We have addressed the underlying cause, and normal functionality has been restored across all systems.
If you continue to experience loading issues, please clear your browser cache, open a fresh browser window, or restart the VCU Mobile app.
Issue
August 24, 2026 · 10:14 EDT
Access to my.vcu.edu and the VCU Mobile app is currently inconsistent. While some users are able to log in normally, others are having trouble loading and may receive error messages.
We have successfully identified the primary issue and a resolution is currently underway. At this time, an estimated time of restoration is unknown.
← Back