Service Outage Reported for myVCU
Minor incident
Web Applications
myVCU Portal
2026-08-16 12:07 EDT
· 1 hour, 56 minutes
Updates
Resolved
August 16, 2026 · 14:01 EDT
The myVCU Portal should be loading correctly once again. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
Issue
August 16, 2026 · 12:07 EDT
We are investigating an issue with myVCU where you can successfully log in but nothing else will load in the portal. We’re working to fix the problem as quickly as we can.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
← Back