Service Outage Reported for Employee Self-Service
Minor incident
University Applications
eServices
2026-08-05 16:34 EDT
· 2 hours, 17 minutes
Updates
Resolved
August 5, 2026 · 18:50 EDT
Employee Self-Service should be up and running. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
Issue
August 5, 2026 · 16:34 EDT
We are investigating an issue with Employee Self-Service which is impacting access to view the Employee dashboard in eServices. We’re working to fix the problem as quickly as we can.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
← Back