Major Incident Reported for DUO Unavailable Error

Major incident Accounts, Access & Security Central Authentication Service Duo Two-Factor
2026-08-03 06:49 EDT · 36 minutes

Updates

Resolved

DUO/CAS should be up and running. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

August 3, 2026 · 07:24 EDT
Issue

We are investigating an Major Incident with DUO Unavailable Error which is impacting CAS logins. We’re working to fix the problem as quickly as we can.
Other Services may also be impacted and will be added as they are identified. If you experience any issues with services not listed, please contact the IT Support Center at 804-828-2227.

August 3, 2026 · 06:49 EDT

← Back