Campus WIde Internet and Network DIsruption

Major incident Internet VCU Campus Network VCU Wireless Network VPN (RamsVPN) Phones Avaya OneX Avaya Workplace Contact Center Services Call Management System (CMS) E-911 Services Telephones
2026-07-29 00:10 EDT · 36 minutes

Updates

Resolved

The Campus Wide Internet and Network is back up and running. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

July 29, 2026 · 00:45 EDT
Issue

The campus is currently experiencing a major network disruption affecting the campus network and internet connectivity. Phone and telecommunication services are also affected. Technicians are presently working to restore service as soon as possible.

July 29, 2026 · 00:10 EDT

← Back