IT Support Center Phone Line (804-828-2227) is unreachable from non-VCU Phones
Minor incident
IT Support & Campus Resources
IT Support Center Services
2026-07-21 12:59 EDT
· 49 minutes, 1 second
Updates
Resolved
July 21, 2026 · 13:47 EDT
The issue affecting our phone lines has been resolved. You may now reach us again from non-VCU phone lines. If you are still having trouble reaching us by phone, please email us at itsc@vcu.edu.
Issue
July 21, 2026 · 12:59 EDT
The VCU IT Support Center phone line at 804-828-2227 is currently unreachable from non-VCU phones. This issue is being looked into by Telecommunications, and we hope to have it restored as soon as possible. You can still reach us at itsc@vcu.edu. If you email us with a callback number, we will contact you as soon as possible.
← Back