Issue inviting external email addresses to Google Calendar events

Minor incident E-mail & Collaboration Google Workspace Google Calendar
2026-07-07 12:02 EDT · 2 days, 23 hours, 44 minutes

Updates

Resolved

Adding external attendees in Google Calendar is now working again. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

July 10, 2026 · 11:45 EDT
Investigating

We are investigating an issue with Google Calendar which is impacting the ability to invite non-VCU email addresses to events. We’re working to fix the problem as quickly as we can.

As a workaround, try creating and saving the event first, then edit the event and invite the non-VCU email addresses to the event.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

July 7, 2026 · 12:02 EDT

← Back