VCU Homepage (vcu.edu) is Currently Unavailable

Minor incident Web Applications Websites
2026-06-22 10:06 EDT · 9 minutes

Updates

Resolved

Access to the VCU homepage (vcu.edu) has been fully restored. All systems are operating normally. Thank you for your patience.

June 22, 2026 · 10:13 EDT
Issue

The main VCU homepage (vcu.edu) is currently experiencing an unexpected outage and is temporarily inaccessible.

Technology Services is actively investigating the root cause and working to restore full functionality as quickly as possible.

June 22, 2026 · 10:06 EDT

← Back