IT Support Center Phone Line Down

Minor Incident with SMS IT Support & Campus Resources IT Support Center Services
2026-06-06 18:22 EDT · 36 minutes

Updates

Resolved

The 804-828-2227 phone line has been restored and is reachable both on and off campus. Please email itsc@vcu.edu if you continue to have issues reaching us at that number.

June 6, 2026 · 18:56 EDT
Issue

The main IT Support Center phone number (804-828-2227) is down and unable to receive calls due to an issue with a telecommunications provider. Please reach out to us via email at itsc@vcu.edu for urgent matters. Agents are monitoring the account and can provide urgent support via Zoom if necessary. Updates will be posted as they become available.

June 6, 2026 · 18:22 EDT

← Back