Central Authentication Service (CAS) Disruption

Minor incident Accounts, Access & Security Central Authentication Service
2026-06-04 20:12 EDT · 15 minutes

Updates

Resolved

The service disruption affecting the Central Authentication Service (CAS) has been resolved. All affected systems and login services are now fully operational.

If you continue to experience issues logging in, please clear your browser cache or contact the IT Help Desk for assistance. Thank you for your patience and cooperation.

June 4, 2026 · 20:26 EDT
Investigating

We are currently experiencing a service disruption with the Central Authentication Service (CAS). You may not be able to log in to services and systems that rely on CAS. Technicians are working to resolve the issue as quickly as possible.

June 4, 2026 · 20:12 EDT

← Back