OnePrint - Student Printing
Minor incident
Printing
VCU OnePrint
2026-05-18 10:59 EDT
· 25 minutes
Updates
Resolved
May 18, 2026 · 11:21 EDT
Students should now be able to release print jobs using their VCUCard.
We appreciate your patience while we worked with the vendors to troubleshoot and resolve the issues, and again, we apologize for the inconvenience.
Issue
May 18, 2026 · 10:59 EDT
Due to a recent change with RamsBucks transactions students have reported issues with not being able to release print jobs using their VCUCard. Students may be able to release print jobs in the interim by manually entering their eID and password.
We are continuing to work with the vendors to troubleshoot and resolve this issue. We apologize for the inconvenience and will provide updates as soon as additional information becomes available.
← Back