Assignment Submissions Using Turnitin within Canvas

Minor Incident with SMS Teaching & Learning Canvas
2026-05-04 11:45 EDT · 1 day, 2 hours, 9 minutes

Updates

Resolved

Turnitin should be up and running. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

May 5, 2026 · 13:54 EDT
Investigating

Students and Instructors may be experiencing issues submitting assignments through Turnitin (TII). We appreciate your patience as we work with the vendor to identify and resolve the problem.

May 4, 2026 · 11:45 EDT

← Back