Kaltura Integration within Canvas Issue
Minor incident
Teaching & Learning
Canvas
Kaltura
2026-05-01 08:54 EDT
· 3 days, 34 minutes
Updates
Resolved
May 4, 2026 · 09:27 EDT
Kaltura should be up and running. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
Investigating
May 4, 2026 · 09:27 EDT
Kaltura should be up and running. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
Issue
May 1, 2026 · 08:54 EDT
We are investigating an issue (error: invalid client) with launching Kaltura content from within Canvas.
← Back