Service Issue Reported for RamsCentral

Minor incident IT Support & Campus Resources IT/HR Support Portal (RamsCentral)
2026-04-15 11:33 EDT · 5 hours, 7 minutes

Updates

Monitoring

We’re back! RamsCentral should be up and running. Thanks for bearing with us! While a fix has been implemented by our service provider, we will continue to monitor behavior in the system.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

April 15, 2026 · 12:09 EDT
Issue

We are investigating an issue with RamsCentral giving a 500 error when loading Business Objects and Dashboards. If you receive a 500 Error, a browser refresh should clear the error. We are noticing that it may take more than one refresh to clear the error. Our service provider have technicians working to fix the problem as quickly as they can.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

April 15, 2026 · 11:33 EDT

← Back