Major Incident Reported for Multiple Services

Major incident Accounts, Access & Security Central Authentication Service
2026-04-12 23:20 EDT · 13 hours, 3 minutes

Updates

Resolved

We’re back! Throughout the morning, VCU IT Services have remained accessible. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

April 13, 2026 · 12:22 EDT
Monitoring

We’re back! Connectivity to VCU IT Resources should be up and running. Thanks for bearing with us! We are continuing to monitor service availability.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

April 13, 2026 · 00:05 EDT
Issue

We are investigating a Major Incident with many VCU IT Services. We have technicians actively working to identify the issue and hope to fix the problem as quickly as we can.

April 12, 2026 · 23:20 EDT

← Back