Scheduled Maintenance for VCU Login (CAS) Upgrade from 2026-03-11 05:30 EDT to 2026-03-11 07:00 EDT

Scheduled maintenance Accounts, Access & Security Central Authentication Service
2026-03-11 05:30 EDT · 1 hour, 30 minutes

Updates

Monitoring

The maintenance on the Central Authentication Service (CAS) is now complete, and all authentication services have been restored to full operation.

The issue regarding non-persistent authentication sessions has been resolved. The community should once again experience seamless across all VCU applications that utilize CAS.

While we are not seeing any further disruptions, our engineering team will continue to monitor system health and performance throughout the morning.

If you encounter any lingering login difficulties, please clear your browser cache or try a private window. If the disruption persists, please contact the IT Support Center.

Thank you for your patience as we completed this critical infrastructure upgrade.

March 11, 2026 · 07:00 EDT
Update

Maintenance on the Central Authentication Service (CAS) is proceeding as scheduled. Our team has successfully completed the primary system updates and has transitioned into the validation and testing phase.

Authentication sessions are not currently persisting across platforms consistently. Please expect a login prompt for every individual application accessed during the remainder of this window.

March 11, 2026 · 06:00 EDT
Update

The scheduled upgrade to the Central Authentication Service (CAS) has begun. Our engineers are currently implementing the initial configuration changes.

The community may now begin to experience intermittent login disruptions across VCU applications.

We will provide another update as we reach the midpoint of the maintenance window.

March 11, 2026 · 05:00 EDT
Scheduled

Please be advised that Technology Services will be performing a critical upgrade to the Central Authentication Service (CAS) on the morning of Wednesday, March 11, 2026.

  • Maintenance Window: 5:00 AM – 7:00 AM (EST)
  • Change Management ID: 6739
  • Impact: Our community may experience interruptions or be unable to log in to many VCU applications (e.g., Canvas, Google Workspace, eServices) during this period.

If you are already logged in to an application before the maintenance begins, your session may remain active, but new logins will be unavailable while the upgrade is in progress.

We appreciate your patience as we work to improve our authentication infrastructure.

March 9, 2026 · 15:02 EDT

← Back