Service Outage Reported for RamsCentral

Minor incident IT Support & Campus Resources IT/HR Support Portal (RamsCentral)
2026-03-02 09:26 EST · 41 minutes

Updates

Resolved

We’re back! RamsCentral should be up and running as expected. We will continue to monitor performance. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

March 2, 2026 · 10:06 EST
Monitoring

We are continuing to investigate and resolve an issue with RamsCentral which is impacting performance and authentication. While the system is back online and accessible, we are noticing intermittent performance degradation. We’re working to fix the problem as quickly as we can.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

March 2, 2026 · 09:40 EST
Issue

We are investigating an issue with RamsCentral which is impacting the ability to log in or load the system. We’re working to fix the problem as quickly as we can.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

March 2, 2026 · 09:26 EST

← Back