Service Outage Restored for OnePrint

Minor incident Printing VCU OnePrint
2026-02-16 08:06 EST · 6 hours, 25 minutes

Updates

Resolved

All VCU OnePrint services remain operational at this time and all issues have been resolved. Thanks for bearing with us! Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

February 16, 2026 · 14:21 EST
Issue

We’re back! [OnePrint] should be up and running. Thanks for bearing with us! Please note some OnePrint devices may require a reboot to fully restore printing.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

February 16, 2026 · 08:06 EST

← Back