Service Issue Reported for RamsCentral

Minor incident IT Support & Campus Resources IT/HR Support Portal (RamsCentral)
2025-12-17 09:33 EST · 3 hours, 53 minutes

Updates

Resolved

We’re back! RamsCentral should be up and running. Thanks for bearing with us!

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

December 17, 2025 · 13:26 EST
Issue

RamsCentral is experiencing severe service degradation related to processing Status Actions and other Quickactions. We are working with the vendor to resolve this as quickly as possible.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

December 17, 2025 · 09:33 EST

← Back