Service Issue Reported for SmartSheet

Minor incident University Applications Smartsheet
2025-12-02 10:53 EST · 3 hours, 35 minutes

Updates

Resolved

Smartsheet has applied a fix, and the login and automation email issues have been resolved.

December 2, 2025 · 14:28 EST
Investigating

We are investigating an issue with SmartSheet which is impacting login and automated workflow emails not being delivered. We’re working to fix the problem as quickly as we can.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

December 2, 2025 · 10:53 EST

← Back