Jamf & Self Service Outage

Major incident IT Resources Jamf
2025-10-31 10:01 EDT · 3 hours, 13 minutes

Updates

Resolved

The outage affecting Jamf and the Self Service application, reported earlier today, is now resolved.

All services are operating normally. Users can now access the Self Service application to install software and request administrator access. Automatic software updates and computer policies will also resume as expected.

If you continue to experience issues with Self Service, please try restarting your computer. If the problem persists, please contact the IT Support Center with at 804-828-2227 or itsc@vcu.edu.

We apologize for the inconvenience this may have caused and thank you for your patience.

October 31, 2025 · 12:12 EDT
Investigating

We are currently experiencing a major outage with our Jamf service, which manages university-computers and provides the Self Service application.

  • The Self Service application is currently unavailable.
  • Users will be unable to sign in to Self Service to install software or request administrator access.
  • Automatic software updates and other background settings for computers may also be delayed until service is restored.

Our teams are aware of the issue and are working with the vendor (Jamf) to restore service as quickly as possible. We will provide an update as soon as more information is available.

If you urgently need to install software or require administrator access, please contact the IT Help Desk for manual assistance.

October 31, 2025 · 10:01 EDT

← Back