Top Hat Gradebook Failing to Update

Minor incident Teaching & Learning Top Hat
2025-10-02 16:08 EDT · 1 day, 5 hours, 10 minutes

Updates

Resolved

Top Hat has confirmed this issue has been resolved.

Queued grades have now been successfully processed for all question types and attendance as of 7:09pm ET today.

There are a small number of secure attendance grades that will be reprocessed early next week to account for geolocation. This means Top Hat expects a small subset of secure attendance grades to be corrected early next week to account for geo-verification - this is expected behaviour.

October 3, 2025 · 21:17 EDT
Monitoring

Top Hat’s system upgrade successfully completed at 6:40am ET. They are currently monitoring their system as backlog queued grades continue to process.

October 3, 2025 · 08:04 EDT
Issue

Top Hat is currently investigating an issue with the Gradebook where grades are failing to update. This issue is preventing instructors from updating grades. While students can still submit responses, their grades will not appear right away.

To resolve this, the Top Hat engineering team will be migrating the database. During this time, all submissions will be safely queued and processed once the migration is complete. To minimize disruption to ongoing evening classes, Top Hat’s engineering team plans to begin the database migration for the US server at 8:00 PM EST. During this period, users can expect significant service degradation, including increased latency and slower load times. The migration will take several hours to complete.

For more information please visit: https://status.tophat.com/incidents/f6j9r29p5l21

October 2, 2025 · 16:08 EDT

← Back