Service Outage Reported for Central Authentication Service (CAS)
Minor incident
Accounts, Access & Security
Central Authentication Service
2025-09-25 08:30 EDT
· 47 minutes
Updates
Resolved
September 25, 2025 · 09:16 EDT
We’re back! Central Authentication Service (CAS) should be up and running. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
Investigating
September 25, 2025 · 09:02 EDT
We are investigating an issue with Central Authentication Service (CAS) which is impacting authentication to various VCU Resources. We’re working to fix the problem as quickly as we can.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
← Back