Service Degradation Reported for RamsCentral
Minor incident
IT Support & Campus Resources
IT/HR Support Portal (RamsCentral)
2025-09-10 13:17 EDT
· 2 hours, 2 minutes
Updates
Resolved
September 10, 2025 · 15:18 EDT
RamsCentral is operating normally again. While we are resolving this alert, we will continue to monitor performance. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
Investigating
September 10, 2025 · 13:17 EDT
We are investigating an issue with RamsCentral which is impacting performance. While some dashboard elements for IT Analysts may not load, much of the general functionality with RamsCentral remains working albeit a bit slow. We’re working to fix the problem as quickly as we can.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
← Back