On-Campus Network Connectivity Alert
Minor Incident with SMS
Internet
VCU Campus Network
VCU Wireless Network
2025-08-30 15:26 EDT
· 13 minutes, 1 second
Updates
Resolved
August 30, 2025 · 15:38 EDT
Internet Service Restored
The intermittent internet issues on the VCU on-campus network have been resolved. You should now be able to access all websites without any issues. We apologize for the inconvenience and appreciate your patience.
Issue
August 30, 2025 · 15:26 EDT
We’re currently investigating an issue with our on-campus network. This might be preventing you from reaching websites. We are working to resolve the issue as quickly as possible and will provide an update shortly.
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.
← Back