Internet Outage

Major incident Internet & Phones VCU Campus Network VCU Wireless Network
2025-08-07 17:36 EDT · 4 hours, 44 minutes

Updates

Resolved

Internet Service has been fully restored and is stable.

August 7, 2025 · 22:19 EDT
Monitoring

Internet connection has been restored. We will continue to monitor the situation.

August 7, 2025 · 19:19 EDT
Monitoring

Technology Services is currently investigating an Internet outage affecting a the VCU MPC Campus, MCV Campus as well as satellite offices.

August 7, 2025 · 17:36 EDT

← Back