Email Delivery Delays
Minor incident
E-mail & Collaboration
Google Workspace
Gmail
2025-07-15 10:26 EDT
· 12 hours, 55 minutes
Updates
Monitoring
July 15, 2025 · 11:53 EDT
A workaround is in place and all emails that were delayed earlier have now been delivered. Our teams are working on resolving the root cause.
Issue
July 15, 2025 · 10:26 EDT
We are currently seeing delays in email delivery as emails are waiting to be delivered. We have identified the cause and a solution is in progress.
← Back