The Software Center is experiencing a disruption.

Incident
October 26, 10:57am EDT

The Software Center is experiencing a disruption.

Status: closed
Start: October 24, 9:18am EDT
End: October 26, 10:57am EDT
Duration: 2 days 1 hour 39 minutes
Affected Components:
Teaching & Learning Software Center
Update

October 24, 9:18am EDT

October 24, 9:18am EDT

Some software titles available at https://ts.vcu.edu/software-center/ cannot be downloaded at this time. Some users may receive a "500 - Internal server error" message. Technology Services staff are actively investigating this issue.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

October 26, 10:57am EDT

October 26, 10:57am EDT

The Software Center should be up and running normally. 

Please get in touch with the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.