Email Delivery Delay from VCU Health Addresses

Informational
June 02, 8:50am EDT

Email Delivery Delay from VCU Health Addresses

Status: closed
Date: June 01, 11:30am EDT
End: June 02, 8:50am EDT
Duration: 21 hours 20 minutes
Affected Components:
E-mail & Collaboration Google Workspace Gmail
Update

June 01, 11:30am EDT

June 01, 11:30am EDT

Customers are experiencing delays in receiving email to their VCU email accounts sent by VCU Health email accounts. VCU Health has determined the cause of the issue and is actively working to resolve it.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

Resolved

June 02, 8:50am EDT

June 02, 8:50am EDT

Email sent by VCU Health addresses is now arriving as expected and without delay. 

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.