VCU websites may currently be inaccessible to selective geographic clients.

Incident
May 04, 4:25pm EDT

VCU websites may currently be inaccessible to selective geographic clients.

Status: closed
Start: May 04, 3:13pm EDT
End: May 04, 4:25pm EDT
Duration: 1 hour 11 minutes
Affected Components:
Web Applications Websites
Update

May 04, 3:13pm EDT

May 04, 3:13pm EDT

Clients located in Europe and other global regions may experience difficulties accessing VCU websites. We apologize for any inconvenience caused and working to resolve the issue. 

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

Resolved

May 04, 4:25pm EDT

May 04, 4:25pm EDT

We're back! Customers across the globe are now able to access vcu.edu and other VCU websites with no issues.

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.