Listserv and Listplex Maestro currently unavailable

Incident
March 28, 3:38pm EDT

Listserv and Listplex Maestro currently unavailable

Status: closed
Start: March 28, 8:45am EDT
End: March 28, 3:38pm EDT
Duration: 6 hours 52 minutes
Affected Components:
E-mail & Collaboration ListPlex Maestro Listserv
Update

March 28, 8:45am EDT

March 28, 8:45am EDT

We are investigating an issue with Listserv and Listplex Maestro which is impacting being able to reach the service. We’ve reached out to the vendor who has a posted alert which may be monitored at lsoft.com. Delivery of emails via Listserv and Massmail is currently delayed until the system is restored.

Update

March 28, 3:36pm EDT

March 28, 3:36pm EDT

We’re back! Listserv and Listplex Maestro should be up and running. Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.

Resolved

March 28, 3:38pm EDT

March 28, 3:38pm EDT

We’re back! Listserv and Listplex Maestro should be up and running. Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.