itsupport.vcu.edu and IT Analyst access to Cherwell are currently unavailable
Incident
March 28, 11:09am EDT
itsupport.vcu.edu and IT Analyst access to Cherwell are currently unavailable
Status: closed
Start:
March 28, 7:05am EDT
End:
March 28, 11:09am EDT
Duration: 4 hours 4 minutes
Affected Components:
IT Support & Campus Resources
IT Support Portal (Cherwell)
Update
March 28, 7:05am EDT
March 28, 7:05am EDT
Overnight, we experienced an issue which is preventing access to itsupport.vcu.edu and the IT Analyst access to Cherwell. We are working with the vendor to resolve this issue.
Resolved
March 28, 11:09am EDT
March 28, 11:09am EDT
We’re back! itsupport.vcu.edu and the IT Analyst portal for Cherwell should be up and running. Thanks for bearing with us!
Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.