Canvas Loading Issue

Unavailable
September 21, 3:13pm

Canvas Loading Issue

Status: closed
Start: September 21, 2:16pm
End: September 21, 3:13pm
Duration: 56 minutes
Affected Components:
Teaching & Learning Canvas
Update

September 21, 2:16pm

September 21, 2:16pm

Our service provider for Canvas is currently experiencing an issue which is affecting customer's ability to login, load or access content. 

We will resolve this incident once we have received confirmation the issue has been resolved from our service provider. 

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu. 

For additional information and updates - (https://status.instructure.com/)  

Resolved

September 21, 3:13pm

September 21, 3:13pm

We’re back! Canvas should be up and running.

Around 2pm today, Instructure (the vendor who maintains/hosts Canvas) reported slowness and errors when accessing Canvas. This also impacted the performance of our Canvas instance, as well as many other institutions. At 2:26pm, they implemented a fix which slowly brought service back. By 2:43pm, service was completely restored and Instructure is continuing to monitor for any further issues.

Thanks for bearing with us!

Please contact the IT Support Center with any questions or concerns at 804-828-2227 or itsc@vcu.edu.